Reports of Users Experiencing Slowness and Login Issues

Incident Report for Restaurant365

Resolved

Fix was implemented and we are now seeing reports of full recovery for Customer Financial Reporting (CFR). We will now mark this incident as resolved.
Posted May 21, 2026 - 13:37 PDT

Identified

Upon investigation, we’ve confirmed the issue is only impacting Customer Financial Reporting (CFR). We have identified the root cause and are currently implementing a fix.
Posted May 21, 2026 - 13:27 PDT

Investigating

We are currently investigating reports of users experiencing slowness and login issues
Posted May 21, 2026 - 12:02 PDT
This incident affected: Website (Customer Databases) and Reporting (My Reports, Custom Financials Reporter, R365 Intelligence).