Based on continued recovery reports, we can confirm the issue has been resolved.
Posted Jan 15, 2026 - 05:54 PST
Update
We are actively monitoring the implemented fix and continuing our investigation to ensure system stability.
Posted Jan 14, 2026 - 15:36 PST
Update
We are actively monitoring the implemented fix and continuing our investigation to ensure system stability.
Posted Jan 14, 2026 - 07:52 PST
Update
We will continue to monitor the fixes that have been implemented and closely observe system performance. The status page will remain in a monitoring state through tomorrow while we ensure continued stability.
Posted Jan 13, 2026 - 14:49 PST
Update
Intraday polling has resumed and is no longer paused. We are actively investigating reports of slowness and closely monitoring system performance to ensure stability.
Posted Jan 13, 2026 - 11:15 PST
Update
As part of our ongoing investigation, we will be temporarily pausing intraday polling. Customers should expect a delay in intraday polling for approximately 45 minutes
Posted Jan 13, 2026 - 10:08 PST
Update
We are continuing to monitor for any further issues.
Posted Jan 13, 2026 - 09:02 PST
Update
We are aware of additional reports of slowness and are continuing to investigate the root cause and assess impact.
Posted Jan 13, 2026 - 09:01 PST
Update
We are continuing our efforts to monitor the fix that was implemented and seeing signs of full recovery.
Posted Jan 13, 2026 - 06:13 PST
Update
We are continuing to monitor the fix that was implemented and are seeing signs of recovery.
Posted Jan 12, 2026 - 14:30 PST
Update
While we continue to see reports of recovery, we will continue to monitor the fix implemented with databases being fully operational.
Posted Jan 12, 2026 - 11:52 PST
Monitoring
A fix has been implemented and we are seeing recovery for both the reported slowness and delayed reporting. We will continue to monitor the fix implemented before fully resolving the incident.
Posted Jan 12, 2026 - 11:43 PST
Investigating
We are currently investigating reports of intermittent slowness within customer instances
Posted Jan 12, 2026 - 10:58 PST
This incident affected: Website (Customer Databases), Reporting (Ad Hoc, My Reports, Custom Financials Reporter), and Connected Integrations (POS Integrations (DSS Polling)).