R365 Payroll Degradation

Incident Report for Restaurant365

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 14:04 PDT

Update

We are continuing to monitor for any further issues.
Posted Apr 08, 2026 - 08:56 PDT

Monitoring

A fix has been implemented, and we're monitoring the situation.
Posted Apr 08, 2026 - 08:56 PDT

Identified

The root cause has been identified, and a fix is being prepared.
Posted Apr 08, 2026 - 07:44 PDT

Investigating

We are investigating reports of site slowness within the R365 Payroll module.
Posted Apr 08, 2026 - 07:33 PDT
This incident affected: Website (R365 Payroll).