System Slowness

Incident Report for Restaurant365

Resolved

We are no longer seeing slowness on the reported pages or grids.
Posted Jul 07, 2025 - 09:22 PDT

Monitoring

A fix has been implemented, and we are seeing recovery.
Posted Jul 07, 2025 - 08:56 PDT

Identified

Our team has identified the root cause of this issue, and are working towards resolution.
Posted Jul 07, 2025 - 06:19 PDT

Investigating

We are currently investigating reports of site-wide slowness affecting a small number of customers.
Posted Jul 07, 2025 - 06:01 PDT
This incident affected: Website (Customer Databases) and Reporting (My Reports).